White screen wordpress from quick install app

Hello I recently installed wordpress from quick install but I am getting a white screen while trying to customize the site theme, I’ve attached an image to the problem.
I already read one thread saying it could be php version but I am using astra which supports php 8.

Also tried deleting everything to make sure it wasn’t an error that I did on accident while using quick install and this is a default install and I still get loading error

check your error logs.

Are you using Cloudflare?

strong text

None of my error logs show a error that isn’t involved without a svg error

Yes, I am using cloudflare.

Could it be that I am not using the dns settings inside of the hestia panel and only using cloudflare?

I have even installed everything on a fresh server and I still get the same issue.
new domain
new cloudflare routes
new ip
new server
fresh wordpress install from quick install app

DNS configuration within Cloudflare shouldn’t cause issues in and of itself. However, I’ve had issues with Cloudflare proxying parts of the WordPress backend on some of my sites, resulting in white or “empty” pages like the ones you’ve attached.

If you’re proxying traffic (i.e. the orange cloud is enabled), you can disable the caching part of Cloudflare using a page rule for your WordPress backend. Do keep in mind this is out of scope for HestiaCP, but it seems like this might be the cause of your issue…

Cloudflare Dashboard > Rules > Page Rules > Create Page Rule

You can use mine (for stangerup.net) as an example. Please remember to utilise your own domain, and remember to include /wp-admin* in the URL - for example: www.example.com/wp-admin*

Next, configure the following settings:

Then save and deploy the page rule. You may have to purge the Cloudflare cache for your domain for all changes to take effect.

Please let us know if this did the trick. Again, I’m guessing this may be the problem. Without any log files, we have a hard time estimating the root cause of your issue :slight_smile:


You’ve fixed my problem, I thought it was my php version, I would’ve never figured this out without spending a lot more time thank you!


Do you mind telling me how you debugged this issue originally?
And why would caching be the root issue?


I initially fiddled around with PHP, Nginx, and even Redis. Nothing worked until I remembered I was using Cloudflare. The page rule setup is a combination of Cloudflare’s recommended rules and a guide on WordPress security (using Cloudflare).

The philosophy of targeting a specific URL such as /wp-admin* can also be applied to other WordPress URLs. For example, you can use Cloudflare Access (Zero Trust) to add an additional layer of security to /wp-login.php* or another page rule to tune the optimization settings for media in /wp-content/uploads/*

And why caching? Cloudflare’s pretty smart and tries to cache often-used resources on your site, which is great for serving identical frontend pages, but impractical for backend systems such as the one in WordPress, where you don’t want anything to be cached as you are doing live editing e.g. in the block editor or plugins.

Conclusion: When using a CDN like Cloudflare, you have to make small adjustments to individual parts of your site to accomplish the best performance, security, and - sometimes - for things to even work :innocent:

Hope this sheds some more light on the matter.

1 Like

I spoke a bit too soon
I could only get it to load if I click on another layout but it is still broken and this is a fresh build of hestia quick install

Try clearing your browser cookies

No, it didn’t help

Oh well, that was problematic…

Please check the output of /var/log/{web}/domains/{domain}.error.log for possible errors/issues

{web} = apache2 or nginx
{domain} = the domain in question

I’m heading to bed soon, I wish you good luck with further troubleshooting. Maybe someone else can succeed where I failed :melting_face:

Also, try temporarily enabling Developer Mode on Cloudflare to rule it out completely.

1 Like

There are no errors for the domain.

Please show the output using e.g.

cat /var/log/{web}/domains/{domain}.error.log

If there are no errors, I could suspect something local. Are you using any adblockers etc.? If possible, try a different browser or preferably a different computer to check if it’s the same.
Check for local browser errors too.

I decided to use a provider that has wordpress as I couldn’t figure out what was wrong.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.