ARM systems support

Hello,

As a person who owns a dozen of arm boards i would be interested to see if is there any plans on bringing the support on Hestia.

Thanks,
George

Hi @root

Currently, there are no plans to support arm processor structures. If anyone wants to expand it, we are as always open for any input or pull requests!

1 Like

Completely understand and hopefully will see if this get’s some support behind, atm i use this (no advertise intended) yunohost (dot) org/#/admindoc they fully support the arm, maybe we can look at their approach (no expert on this so not sure if even related)

Thanks,
George

Hi @ScIT.

What would be necessary for having an ARM version available? I’m happy to try and find a way to make it compatible, as it seems like more companies are offering Raspberry Pi-based hosting nowadays, and also many people want to use a Raspberry Pi at home as a way to start learning about web servers.

I was testing a few things this weekend but a part from not having an update version of MariaDB, not having an ARM version of Hestia packages in the repositories was preventing me to continue investigating. Is there any way to install Hestia from GitHub instead of using the repos?

To build the packages your self

1 Like

Brilliant. Thank you very much. I will give it a try tonight.

1 Like

Well, it seems that changing BUILD_ARCH to arm64 allows sudo ./hst_autocompile.sh --hestia main Y and sudo ./hst_autocompile.sh --nginx main Y to compile just fine on a Rasbperry Pi 4 with Ubuntu x64. I’m going to try now PHP, which is always the most difficult.

For PHP… At some point I have the errors

mkdir: cannot create directory 'main/.libs': File exists
mkdir: cannot create directory 'Zend/.libs': File exists
mkdir: mkdir: cannot create directory 'sapi/fpm/fpm/events/.libs': File exists
cannot create directory 'sapi/fpm/fpm/events/.libs': File exists
mkdir: cannot create directory 'sapi/phpdbg/.libs': File exists

And then I start having a lot of errors (these are just an excerpt):

cc: fatal error: Killed signal terminated program cc1
compilation terminated.
cc: fatal error: Killed signal terminated program cc1
compilation terminated.
make: *** [Makefile:835: ext/fileinfo/libmagic/apprentice.lo] Error 1
make: *** Waiting for unfinished jobs....
cc: fatal error: Killed signal terminated program cc1
compilation terminated.
make: *** [Makefile:1177: ext/opcache/Optimizer/zend_inference.lo] Error 1
make: *** [Makefile:715: ext/pcre/pcre2lib/pcre2_jit_compile.lo] Error 1
mkdir: cannot create directory 'sapi/fpm/fpm/.libs': File exists
cc: fatal error: Killed signal terminated program cc1
compilation terminated.
make: *** [Makefile:1125: ext/opcache/ZendAccelerator.lo] Error 1

I will try to not use PHP and see what happens.


UPDATE: Installing dependencies with HestiaCP installation script also fails… I will try tomorrow to modify the script and see what I can do…

1 Like

Please let me know if you find a a solution I have few boards that I would like to scale them up and make a server.

So far, I’m having no luck… :confused: I will have to invest a bit more of time…

Hi,
just playing around, but it seems that i successfully compiled ARM64 hestia 1.4.0 (alpha) on RPI 4B (4GB RAM).

BTW, installation still doesn’t works. I think that it could works if control files fetched from hestia repo during compiling are tagged as arm64 instead of amd64 :

What i did

Setup a fresh debian 10 environment on RPI (tested but still “unofficial” images from Tested images

Check updates

download and edit hst_autocompile by changing arch as suggested by @realjumy hestiacp/hst_autocompile.sh at main · hestiacp/hestiacp · GitHub

start compile package in debug mode

and then try to install the package with the obvious error
image

I’ not spednig a lot of time, but it could be cool if someone can test it as well. :slight_smile:

Please check:
https://docs.hestiacp.com/development/panel.html

Will use local source instead main branch.
./hst_autocompile.sh --all --install '~localsrc'

Also the hestia package won’t be the issue if there is an issue it will be hestia-nginx / hestia-php

Fork HestiaCP and clone it

Modify: hestiacp/control at main · hestiacp/hestiacp · GitHub and replace

Architecture: amd64

With

Architecture: armhf or arm64

Please note depending on your OS

Do the same for:

Modify

to the correct architecture

Build the packages as above

./src/hst_autocompile.sh --all --install '~localsrc'

Then wait xx min to compete

Then go to:

And remove the [amd64] before the source and then install Hestia with

bash hst-install-{os}.sh --with-debs /tmp/hestiacp-src/deb/

Please note I have only tested it on raspberry pi OS (RPI 4.0) and it broke after the install / config mysql. Feel free to take it further from here.

Hi @eris ,

thank you for your hints. I just tried with the official RPI OS image (Debian based). I think something is moving forward because i got few compiling errors just for PHP. HEstia, Nginx and all the rest are fine.

Once ready, i tried to install the package and no errrors for mysql or any other package and/or library except for PHP.

Doing a systemctl status hestia.service i got :

IMHO, it seems the only thing that needs more workaround is PHP.

I check again during this week if I have time.

Thank you

It is normal to see a lot of error messages during compelling. Mainly for hestia-nginx and hestia-php packages.

Got it working without any “Issues”


To get it working on an PI

Install Ubuntu 20.04 for ARM 64 on the SSD
Install Git:
Clone GitHub - hestiacp/hestiacp: Hestia Control Panel | A lightweight and powerful control panel for the modern web.
Then:
cd hestiacp/src/

Then follow the steps on:
https://docs.hestiacp.com/development/panel.html#install-hestia-from-packages

In case of the errors @realjumy and @Ubi had increase your memory. In the cause it is not possible assign a swap volume.

Durring testing / building it ran out of memory even with 8GB availble.

Then run the installer

2 Likes

Nice! I will give a try this week! :slight_smile:

If you want the ready build packages ping me via Discord…

Created a pull request with all the changes

2 Likes

This is absolutely fantastic!

I will try to give it a go this weekend. I really hope this works. Some VPS providers such as Mythic-Beasts give an excellent service for the price when using their Raspberry Pi server hosting. The only problem is that they only provide 4GB of RAM…

I really hope an official ARM version will be provided in the future from Hestia.