Last apt upgrade of roundcube broke it!

Hi all.

I’m getting a new Hestia 1.1 installation set up on Debian 10. A few nights ago I ran the routine Debian apt package upgrades and for some reason the roundcube package went through the whole installation process as if it was being installed for the first time—asking if I wanted to use MySQL or PostgreSQL, for example. That seems to have wiped out the configuration, because now—regardless of which I go to, it has the “Server” field along with “Username” and “Password” on the login page, and won’t allow logins without it.

Before I start digging into troubleshooting this, I just wanted to see if anyone else has had this happen, and if so, what you did to fix it.


Hi Dan

Currently we do not have any knowledge about a pending roundcube upgrade issue. May I ask you to start debug, so you can provide us more informations?

Yeah, I’ll dig through it this weekend when I get a chance. I’m getting close to having this ready to transfer my personal friends/family Zimbra server over to a new VM with Hestia. The last thing I needed to do was get the IMAP Sieve Spam/Ham learning thing working with Rspamd (I’m really looking forward to that feature), then this came up. Always something :smile:


Okay… So far, the only thing I’ve found that changed was that the upgrade of the roundcube package replaced Hestia’s /etc/roundcube/ with the default that comes in the package. Somehow, however, it renamed the one that it replaced to “”! So I renamed the new file, then renamed back to and now roundcube seems to be working normally again.

Strange. Something to keep an eye on next time anyone does a routine “apt upgrade” and roundcube is in the list of packages being upgraded.


1 Like

Hi Dan

Thanks for your update, if roundcube has overwritten your config during the upgrade, that would be verry weird. We’re going to monitor the issue from our side abd try to rebuild it.

Usually we get a question/warning when there is a new config that’s different from the existing config, asking if we want to overwrite/replace/keep the existing config. The default reply is to keep the existing config. Indeed it sounds strange that a config file was replaced with just apt upgrade. Maybe some special command line option for apt upgrade?

1 Like

I can confirm that roundcube webmail was also broken on Debian 9 apt-get upgrade install.

roundcube-core 1.2.3+dfsg.1-4+deb9u4
roundcube-mysql 1.2.3+dfsg.1-4+deb9u4
roundcube-plugins 1.2.3+dfsg.1-4+deb9u4

To the best of my memory, it asked if you already had a database which I replied yes and I selected to keep my existing config file (no modifications to be made). After this webmail ceased working.

I meant to post this when it happened to me sometime around 5/7/20. The fix was to simply upgrade to the latest version of roundcube which for me was 1.4.4. Following that it all worked again.

You can follow the instructions by opening the forum post below.

Not sure why it broke but the fix was pretty painless.

Same thing happened again (Debian 9) and I definitely choose the keep my local config option.

The following packages broke the webmail.

roundcube-core 1.2.3+dfsg.1-4+deb9u5
roundcube-mysql 1.2.3+dfsg.1-4+deb9u5
roundcube-plugins 1.2.3+dfsg.1-4+deb9u5

The fix was to upgrade to 1.4.6. from my previous 1.4.4.

I guess this is one way to make sure I’m on the latest Roundcube version. Others might not be so happy 'tho to have the webmail breaking.

Basicly we can’t do much here: Hestia uses the default version of roundcube and adjust the configuration file. If this file now gets overwritten from a roundcube update, then you need to do a request to the maintainers of roundcube - this is out of the range of hestia.

The issue didnt occure on my systems (ubuntu 18.04).