File Manager "unknown error" I dont have root access

Good day Everyone,

Ubuntu: 20.04
HestiaCP: 1.6.8

Please I need your help, before I was able to browse our website’s file manager without this error, but when I add a new user for purpose of test website, now the issue occur, when the admin tries to browse the file manager this error appear “unknown error” (please find the screenshot), I already deleted the user, but same issue, and the problem I don’t have access to our ubuntu server.

Hoping there are ways to fix this issue.

Thank you so much.

Tried to follow the solution by editing the /etc/ssh/sshd_config like this one Unable to open file manager

This is the update /etc/ssh/sshd_config
WhatsApp Image 2024-05-22 at 16.31.20_d572dd78

Still the same unknown error still appears.

Hi @abif,

If you don’t have access to the server as root… it’ll be hard to debug and fix it. As you already modified the sshd_config file and it looks good, you could try to rebuild your user:

To check more thing or trying to fix using another procedure you should have access to the server.

Anyway, did you try to connect to the server using an SFTP client like Filezilla or WinSCP (if you are on Windows) ?

2 Likes

DROPing FTP access from the firewall give the same error but i don’t thing this the case here

1 Like

It should use SFTP so that can’t be the issue

3 Likes

Hi good day,

Thank you so much for the reply, I will try that rebuild user profile.

For the FTP, I tried but still can’t access the server.

Keep in mind that I’m not talking about FTP but SFTP

1 Like

I tried the rebuild user profile, same unknown error appears.

For SFTP, still cant access
image

Is there any chance that the web hosting company can retrieve our server password or credentials?

But why is it timing out? Do you have your SSH port open?

I don’t know how those credentials are managed by your hosting company so maybe… Anyway, if they provide a way to access your server via terminal from their control panel you could modify root credentials. The best you can do is to ask them about this.

1 Like

For the SSH, I am not sure if it’s open, how can I check on that?

Thank you, I already communicated with them, hoping they can give us, the way to access our server.

Server settings -> Firewall and check if there is an ACCEPT rule for your SSH port.

1 Like

For this Firewall, our plan doesn’t have that.

I tried using Putty, I was able to proceed on the log in, but I tried to put the credentials, still access denied. Maybe I should communicate first to the support on this and ask for the access. Will get back to you if I have already access to our server.

Thank you so much Sir.

1 Like

image

is this logged in already? I logged as root

I can’t see the login prompt but seems so, you are logged in.

1 Like

Show the output of this command:

ls -la /home/admin/.ssh/
1 Like

I will try using Filezilla if I can access the server, after your checking. Thank you.

image

Rename the authorized_keys and delete the hst file.

cd /home/admin/.ssh/
mv authorized_keys authorized_keys.backup
rm hst-filemanager-key

And try to use file manager again from admin user.

2 Likes

image

Thank you so much I am now able to access the SFTP.

Can I update here to fix the hestiacp issue unknown error?

1 Like